Metrics for EU region not showing

Minor incident Dashboard
30 minutes, 42 seconds

Updates

Resolved

The issue has been resolved.

October 5, 2020 · 08:38 UTC
Investigating

Missing data for metrics in the EU region.

October 5, 2020 · 08:08 UTC

← Back