Cluster Upgrade from 2020-09-18 07:24 UTC to 2020-09-18 10:24 UTC

Scheduled maintenance Clusters EU Cluster
3 hours

Updates

Update

Updated US Cluster

September 18, 2020 · 08:38 UTC
Update

Updated AS Cluster

September 18, 2020 · 08:38 UTC
Essential

We are updating services.

September 17, 2020 · 07:21 UTC

← Back